Talk:Rescue and Recovery

From ThinkWiki
Jump to: navigation, search

I'd like to note that my R50e shows all the signs of a Rescue and Recovery partition. I have a 4.28 GB Hidden fat32 partition labelled "IBM_SERVICE" according to QTParted. Installing LILO in the MBR also made the Predesktop Area unreachable (no response when pressing "Access IBM" during boot). --Monobryn 17:11, 15 September 2006 (CEST)

Relating to the FIXME: My T42 (2373) has programs called bmgr.exe and bmgr32.exe in C:\IBMTOOLS\utils . I haven't tried them out just yet. More info when I do, and if there's anything conclusive, I'll udpate the actual page. --Daxelrod 23:44, 23 July 2006 (CEST) I've run BMGR, and while there are some interesting registry files near it, it's not at all clear how to use the program. --Whizkid 22:59, 18 December 2006 (CET)

"It is not known how to invoke Rescue and Recovery once GRUB has been installed in the master boot record."

See, Consideration 6:

 The Master Boot Record (MBR) must be configured properly for the 
 Rescue and Recovery application to function properly.  When possible, 
 the Rescue and Recovery application attempts to ensure the proper 
 configuration of the MBR.  This can only occur if the Rescue and 
 Recovery application is installed after other applications that 
 requires the MBR.

Apparently the R and R uses some very specific stuff in the MBR. Maybe Google will help you find some further info (has someone ever looked at the R and R enabled MBR in depth?)

Paul Bolle 13:43, 9 Oct 2005 (CEST)

Having special data in the MBR means less room for code, which may explain why the preinstalled MBR ignores the Active bit and (as far as I can tell) always boots the first partition. The latter means GRUB can't be installed in a partition boot sector either...

--Thinker 14:06, 9 Oct 2005 (CEST)

Why not? If the RnR-MBR always boots the first partition, just go back to the classical recommended partition layout (from the times that LILO didn't support LBA) and create a tiny first partition (that you can i.e. use as /boot partition, which has certain advantages). Install grub into that partition.

Wyrfel 14:44, 9 Oct 2005 (CEST)

I saw posts about the R&R software (or at least some versions thereof) assuming that the Windows partition is the first one.

--Thinker 14:52, 9 Oct 2005 (CEST)

Another hack you might try is to "rebrand" your first partition to some Windows type (I guess you should choose NTFS) without any other change to the fs! (So in reality it's still an ext3 fs or whatever.) If R and R is _non_ destructive (I wouldn't know!) it would be interesting to see how deeply it really checks the first partition. (It shouldn't check too deeply, as it should be able to "rescue" a messed up Windows partition, shouldn't it?)

But chances are this is a pointless hack ...

Paul Bolle 15:16, 9 Oct 2005 (CEST)

Is that true? That would mean you'd have to keep the Windows installation for the R&R system to work. In that case the only way to go would be installing grub4dos on that windows installation.

Wyrfel 14:56, 9 Oct 2005 (CEST)

Another idea/question. Shouldn't it be possible to copy an NT boot sector to a file via dd and chainload that file from GRUB? This way grub could go to the boot sector of the first partition and boot the NT boot sector that may then sit on a Linux filesystem, which in turn would boot the first partition.

Wyrfel 14:59, 9 Oct 2005 (CEST)

Could you please elaborate, Wyrfel? You lost me here ...

Paul Bolle 15:18, 9 Oct 2005 (CEST)

I think chaining GRUB from Windows will work (I don't know about grub4dos, but there's the trick of copying over the GRUB boot sector into a file and telling NTDETECT to load that.)

The trick with putting GRUB into the Windows boot sector and chaning into a copy of the original also sounds like it might work.

Alas, I can test neither, since I eliminated RNR from my disk after it stopped working even with the original MBR restored. No idea why. IBM sure didn't work very hard to make RNR 3.0 compatible with the standard partitioning and boot conventions...

--Thinker 16:12, 9 Oct 2005 (CEST)

For my R50e the claim, that the active bit is ignored is not true. If I remove the active bit or put it to my Linux partitition I get something like missing operation system --[[User:Samba|Samba]

I mean the reverse approach of this.

Copy the NT boot sector into a file, place that file on a linux partition, boot into the file via grub. I don't know if this could at all work. First, grub might not be able to chainload a file, though i believe it is, second, the NT boot sector may not like to be a file. AFAIK, the NT boot sector knows the partition it is suppossed to find NTLDR on. So it wouldn't depend on being the first sector of the same partition.

Wyrfel 01:27, 10 Oct 2005 (CEST)

Success booting R&R from GRUB

The method mentioned on the article (changing the partition type to 0x0b) worked for me on my T42.

You can do that with GRUB:

 parttype (hd0,1) 0x0b

You can add that to a GRUB menu entry that boots the recovery partition, which otherwise looks like this:

 title           IBM Rescue and Recovery
 root            (hd0,1)
 chainloader     +1

(Note that the Access IBM does not work during boot any more -- you have to explicitly choose the R&R partition from the GRUB menu. Good enough for me.)

I think that the recovery partition type is set to 0x12 to hide it from your Windows installation. The preinstalled MBR probably changes the partition type when you press Access IBM, and changes it back on next boot.

Grub for dos is the best solution:

More advice (which didn't work for me without the partition type fix):

Accessing the Recovery Partition if Linux has been installed and the F11 button no longer works]

Set the IBM Predesktop Area (in the BIOS) to “Secure”. Boot using the SUSE DVD. Shrink the Windows partition as required. Follow the instructions and go through the regular installation process. Create a primary partition for /boot (the other stuff can go into the extended partitions) and when the time comes to install GRUB (you do prefer GRUB to LILO, don’t you?), make sure you install it into the boot sector of the boot partition. Set this partition as active. Leave the MBR alone.

The issue and solutions need to be summarized and added to the main article.

--Thinker 19:26, 9 Dec 2005 (CET)

Tried to do just that. Please correct hings if i got something wrong. Wyrfel 14:46, 31 January 2006 (CET)

R52 MBR for those who want to dissect it.

Hi there, I had the issue regarding the blue screen while trying to boot the IBM R&R partition, but the type-changing trick worked. I made a complete factory restore, and I was happy to discover that it fixed the MBR in such a way that the R&R PreDesktop area now works at all times. I've now made a backup of this MBR in case something ever happens (like accidentally putting a better boot loader in it ;-)). It looks quite different compared to a classic Windows XP made MBR, so it might be worth to take a look.

Anyway, for those interested, the R52 MBR can be downloaded here. 10:21, 28 Oct 2005 (CEST)

Thanks for the information. Question: "works at all times" here means:

a) when pressing the Access IBM / ThinkVantage / Whatever button

b) when booted by GRUB (chainloaded by NTLDR?)

c) ?

Paul Bolle 20:52, 28 Oct 2005 (CEST)

Yeah sorry, I could have been more verbose on that part. Actually, what I meant was that pressing the "Access IBM" button launches the R&R area successfully, regardless of the partition being of type 0x12 or 0xb. I'm fairly sure that if anything is changed in the MBR, R&R will be broken once more. I guess some very specific stuff is initialized within the master boot code. I can't risk experimenting with it for now, as the laptop in question isn't mine to begin with.

Also, note that pressing the button doesn't give any other options, apparently. It just immediately boots the R&R partition. When the MBR was tampered with, pressing the button would give a boot menu, where one could choose to enter the BIOS menu, or boot another device. The only way to boot into R&R was to use a separate bootloader (in my case, a GRUB boot CD). 23:19, 28 Oct 2005 (CEST)

It would be rather nice to dissect and discus that MBR. But I'm not sure whether we should encourage to do that on ThinkWiki. Any opinions (other than mere slogans such as: "We should have freedom to tinker!") on this subject would be greatly appreciated. Admins?

Paul Bolle 01:03, 30 Oct 2005 (CEST)

Concerning the encouragement, it should in any case be clearly mentioned that tinkering can cause (serious) damage. For as far as legal issues go, R&R is a trademark, but APS is as well. Reverse engineering is a legal issue in some countries, but not in all. People who dig into this should be aware of their legal situation. That said, i think it's an interesting issue that might shed light into the MBR in general. If the final result gets provided here as a way of how to build a compatible GRUB MBR or something the like, i see no issues with the publication. I think, however, that discussing the fiddling (reverse engineering - if so) process here is not without concerns, because afaik this has legal issues in some countries.

Wyrfel 02:03, 30 Oct 2005 (CET)

I accidently killed my bootsector when I installed Linux, so this image comes in verry handy to restore the "Access IBM" button function. How can I write this image back onto my disk?

-- 22:58, 5 Dec 2005 (CET)

Hello, dealing with a new T43p (installing Ubuntu 5.10) and struggling with the AccessIBM "thing".
There seems to be a way to backup the "special" IBM MBR, and that would give a lot of peace of mind because one could restore that instead of reinstalling everything from the CDs. How can that be done? Just a plain dd on /dev/sda?

I have checked the SUSE Linux, WinXP & Access IBM on the ThinkPad T43 thread on SharadWare, whose bottom line seems to be: don't touch the MBR, put grub in a linux partition and make that the bootable partition.

However, if I do that it does not start with grub. I have posted a longish note there my post.

One of the main outstanding questions to me is: does AccessIBM boot alright if/when called from GRUB if this latter is installed in the MBR?
If so, then I will be happy to go with a normal grub-in-MBR.

Does anybody know the answer?

--GF 00:08, 19 Dec 2005 (CET)

FYI I have just come across this page on the IBM site:
Recovery repair diskette, it seems to make it possible to restore the MBR to the factory installed status, namely it states "This package can also be used to reenable the F11 function as long as the service partition has not been removed from your hard drive."

It could be the lifesaver for heavy-testing moments, because based on my readings more or less the solution seemed to be to reinstall everything.

I have not tried this yet, and I hope I will not need to, but since the system (t43) is new I could invest some time in this... I will keep you posted.

Only question... the instructions are for creating a floppy, but there is not floppy driver in the T43. Will it be ok to create the floppy on any other windows box?

GF [t41, t43p] 01:04, 19 Dec 2005 (CET)

I have tested the Recovery repair diskette on my T43, which was not booting the Rescue and Recovery partition anymore. I have successfully created and used the disk with an USB floppy drive. Everything works now again the same way it used to when the laptop was shipped. The tool on that floppy will offer two different major options:

"1. Repair the current master boot record" and
"2. Replace the current master boot record.".

The first option did not fix the problem with the Rescue and Recovery partition on my system. When selecting the second choice, there were three new "sub-options":

"A: Supports the newer IBM Rescue & Recovery ...",
"B: Supports previous versions ..." and
"C: Supports only the main operating system environment.".

For my system the choice A was successfull.

-- 10:30, 12 Jan 2006 (CET)

Hmm... I just tested this on my T43. The starting point was that I hosed the original MBR by installing grub onto it. "repair the current master boot record" did repair the MBR, but the IBM rescue & recovery was still unaccessible from BIOS (Access IBM). However, replacing the MBR did the trick, so I can boot from grub into linux, winXP and IBM rescue and recovery. The Access IBM key works from BIOS.

Diagnostic tools only

Anybody know how to run the hardware diagnostic tools only from the R&R backup CD's? I can boot off the R&R diagnostic CD, but in order to run diagnostic hardware tests, the cd asks to reboot the system, which will then repeat the process. I do not have the R&R partition on my hdd (backed up before putting Linux on the hdd.) --gsmenden 10:50, 30 Jan 2006 (EST)

Given how R&R launches the hardware diagnostics, it will not work when R&R is run from the CD. It may be possible, using some advance bootloader wizardry, to load the PC-Doctor image directly from the R&R CD, but, other than for extra geek points, it is unnecessary to go through the trouble of trying to figure it out, as Lenovo now provides a bootable PC-Doctor CD image [1]. --Yemartin 04:49, 11 May 2008 (CEST)

Problems with Windows Partition

I have successfully managed to install Kanotix and keeping the "ACCESS IBM"-Key working at the beginning by following the instructions in the way that I installed GRUB in the LINUX-Partition, not in the MBR. However, I can not boot the Windows XP-Partition which I have downsized with Qt-Parted. When I start it I get a GRUB-Error 25, before Installing Linux I got something "invalid ...". From Linux the Partition is fully accessible, so I have 3 theories what is the problem: - I have stopped the Thinkpad-System-Installation just at the point where it was going to convert the file system into NTFS (did not let it reboot at this point), so the problem may have something to do, that the convert utility tampered the file-system - The partition shrinking did not work correctly, at least for Windows standards. - Something wrong with my Grub-configuration, this is less likely since it also did not work, when Linux was not installed. Another problem: After using Diagnostics, the setting of the active partition is changed in the partition table. So the next booting does not work, I have to manually reset it. Any hints? Samba

BTW: Rescue and Recovery is also used with Thinkpad R50e

A recommendation: If you want to keep your Windows Partition and resize it, I can recommend CD. The actual version even resizes, when the partition is fragmented. That is important because the defragmenter within Windows does not defragment correctly.

Moving the R&R Partition

I just got a new hard drive and, since my recovery CDs had gone bad, I wasn't able to just do a reinstallation with the new hard drive (IBM/Microsoft only let you make one copy of the recovery CDs off the hard drive). So, I decided to preserve my current installation by dd'ing the old 40GB hard drive to the new 120GB one. Unfortunately, this led to a fragmented situation since, while I can move my Linux partitions no problem and ntfsresize can grow the NT partition, the rescue partition is smack in the middle of the drive at the 35GB mark. It wasn't enough to make a new recovery partition at the end and dd the current one over because the format of the DOS boot sector depends on the size of the partition and the geometry of the disk. I discovered however, that I could use GNU parted to cp the old R&R partition to the new one and GRUB could then boot it just fine, even though the partition number had changed from 2 to 4. I suspect that using parted's move command would work as well and probably work with the original MBR as well since that would preserve the partition number. Cchiappa 17:32, 20 November 2006 (CET)

rescue and recovery issues


Can I still use the standard "system recovery" windows feature on my Z60? I tried to, but I will always get a failure message and my system will stay as is after the recovery. The thing is that windows recovery makes a backup everytime I switch off the system, while RR requires a time-consuming manual backup.

I currently have "rescue and recovery" installed. Does this have anything to do with the problem?

Problems recovering factory MBR


I wanted to make a factory recovery for some time and tried to do it, but now, my windows partition isn't working, the R&R tried to do something with the MBR but it doesn't work because I have Grub on it and now, that I can't access windows, I lost too the bmgr.exe that recover the factory MBR. I can't recover windows because of the MBR and can't fix the MBR because of the Windows, what should I do ??

Can't Restore to New Drive?

My drive went south so I have a new drive and just want to restore the files under My Documents, not the whole drive. When I do that on the new computer, I see the Documents and Settings folder but when I try to click on it, it says permission denied or something. I didn't restore it to the main C drive because I realized it would clash with the documents and settings folder already there, I restored it to a secondary (D) drive. How can I restore/read these files? This is R&R 4.1 on Windows XP Pro.

Recovering R&R partition from scratch :)

Hello everybody

last time i bought T42, earlier owner has removed R&R partition :( anyway i still have sticker with winxp oem key, and genuine box winxp i would like to get back my R&R partition i can get another T42 (or R40 or T43 or something like that) with R&R partition, is there any posibility to change oem key inside that partition ? i know that's not a problem to copy it, but i would like to use my key

regards stabilob

Partition types with new versions

There are many ToDo notes regarding the partition type with new versions of Rescue and Recovery.

I believe the key difference here is not the version of R&R but the version of Windows. Vista R&R appears to use NTFS with Vista-style imaging technology. Windows XP R&R uses a type 12 FAT32 partition.

This is how you decide which type of MBR recovery disk you need:

I have seen this on ThinkPad T61 and T400 laptops.

--Michael 13:11, 5 March 2009 (UTC)

Recreating Windows 2000 Recovery Partition from scratch

I bought a T23 which had Windows 2000 on a disk image snapshot, with one partition for the whole drive, so since I wanted to use multiple partitions I had to rebuild the whole drive from scratch. I bought one of the recovery CDs off Ebay, but apparently there are two of them; finally I found a bittorrent image of the second one. The IBM-badged OS can be re-installed from the two CDs simply by booting from the first CD (the reload respects the current partition table, and doesn't wipe the whole disk); however, it was very difficult to find out what sort of partition the MBR needed to re-enable the F11 key.

The combination that worked in the end was formatting a 1G partition under Win 98, putting it immediately after the first, labelling it IBM_SERVICE, and making it bootable (ie. using the command: format /V:IBM_SERVICE /S under Win 98). Re-installing the MBR with the command: bmgr.exe /Fboot.bin /Mbmgr.scr then got the F11 key back onto the bootup screen, and rebooting and pressing F11 booted into Win 98.

It was then a matter of copying the first Recovery CDROM onto the second partition, and adding the files 3GGEL6A.CRI and 3GGEL6A.IMZ from the second partition. These last two files are the only new files on the second CDROM, and all the recovery files fitted onto a 1G partition. The Win 98 autoexec.bat file was edited to call recover.bat. Resetting the second partition's type to 0x1C, rebooting, and pressing F11 then re-installed the IBM-badged Windows 2000.


Rescue & Recovery 4.3 not compatible with 4.2 or lower.

I think there should be a note on the article page, though I'm not sure where it should go, much of what is there is on older versions.

Important Notes on Rescue & Recovery 4.3 & Window 7

  • Rescue & Recovery 4.3 is for Windows 7 only.
  • R&R 4.3 can NOT read your backups from 4.2x!!
  • R&R 4.2 can't be installed on Windows 7.
  • To read 4.2 backups you need to boot into a Rescue and Recovery 4.2x environment and make copies of your files there.

From IBM/Lenovo Rescue & Recovery 4.3 Download page:

  • Rescue and Recovery 4.30 is designed for the Windows 7 operating system. The previous versions of the Rescue and Recovery program for Windows 2000, Windows XP or Windows Vista cannot be installed on Windows 7 operating system. Therefore, the Windows Installer does not support the over install behavior from previous versions of the Rescue and Recovery program.
  • If you want to retain the ability to restore from backups created with a previous version of Rescue and Recovery, you must create a copy of your backup files on bootable, external recovery media before installing the latest version.
    1. . To archive your backups, complete the following procedure:
      • From the Rescue and Recovery main screen, click Backup, and then select Copy backups from hard drive from the drop-down list.
      • Select the medium you want to save your backup files to by clicking the appropriate radio button. The backup files that will be copied are listed on the user interface.
      • Click OK to continue
    2. You will need blank removable media when copying backups from the hard drive to CD or DVD. Make sure that you label each disc as it is created, and that you store them together in a safe place.
      • Note: You will be prompted to make the external media bootable at the beginning of the process.

Rct 21:41, 8 December 2009 (UTC)

bmgr32.exe 4.3 is not compatible with SYSTEM_DRV

On Lenovo/W500 with windows 7 "professional" there are the following partitions.

  • Partition Layout
    • Partition 1 is NTFS, active and called SYSTEM_DRV, without drive-letter, 1.1G
    • Partition 2 is NTFS and called Windows7_OS, c:\, 289G
    • Partition 3 is NTFS and called Lenovo, q:\, 10G
  • R&R is Version 4.3
  • Although the first partition is active and bootable with \bootmgr and a BCD store in \boot, the second partition is bootable, too. But with booting the second one directly, the Thinkvantage button will not work.
  • After installing an other Linux/Windows you _can not_ recover the Thinkvantage-Button function with R&Rs 4.3 bmgr32.exe, because it can not find the service-partion. It only looks on NTFS-Partitions for disclabels like IBM_SERVICE or SERVICEVnnn. So SYSTEM_DRV is not valid. I tried to relabel the partition, but to no end.
  • beware of imagex.exe for a complete factory recovery from the Lenovo-Partition files in \FactoryRecovery. It won't write the Lenovo bmgr, so the Thinkvantage button function will not be recovered.
  • The only way I found to do a complete factory-like recovery was this one. You need your usual magic hacker skills and:
    • all the files from q:
    • your Thinkvantage Recovery CD
    • a partition layout like shown above
  • if your installed Windows is without R&R 4.3, the Thinkvantage Recovery CD won't find a Windows to recover and just reboot. You will also need
    • a normal Microsoft Windows 7 Recovery CD (WinPE)
    • imagex.exe from c:\Program Files (x86)\Lenovo\Factory Recovery\imagex.exe
    • know how to use imagex.exe
    • recover c:\ with imagex.exe from q:\FactoryRecovery\cdrivebackup.wim. Your installed Windows with all the applications on it will be deleted!
  • You may create a Thinkvantage Recovery CD by using the files from the Microsoft Windows 7 Recovery CD and copy the file s:\Recovery\WindowsRE\winRE.wim into \sources\boot.wim
  • Boot from the Thinkvantage Recovery CD and choose complete Factory Recovery. s:\ and c:\ will be recovered.
  • After first time booting of Windows 7, the Thinkvantage-Button Function will work again.


Utilities that can read Rescue & Recovyer 4.x backups?

  1. Are there any known utilities that can read Rescue & Recovery 4.2 or earlier backups?
  2. Is R&R written by IBM/Lenovo or is it software that has been OEM'd from somewhere else?