Talk:Problem with unauthorized MiniPCI network card

From ThinkWiki
Jump to: navigation, search

Solution for R32, T43, T6x

Basically solved here. Will be finalized into some user-friendly thing hopefully.

Affected Models

I am unsure about which models this applies to. I have seen reports of this problem affecting a T41p, T43, X40, R31, X31, and T30; but I do not know how far back this problem goes or if there are exceptions. If anyone has better information, please clarify/specify the "Affected Models" section. --Kevinoid 05:44, 14 Dec 2005 (CET)

I have a R40 model 2681-K9G that came without any mini-pci card so I bought a Intel PRO/Wireless 2915ABG mini-pci card for it. When I discovered that it would not work in my Thinkpad I came to this site to see if there was a fix. Seemed like there was, so I bought a mini-pci-to-PCI adapter and installed the card(s) in my desktop. Now I need to know what vendor and device ID strings to use when I flash the card's BIOS. Anyone have a list?

Solution on T43?

There were several edits to the previous page to the effect that "this didn't work for my T43". Although I do not weight this as highly credible (please just ask for help on the ML rather than adding random comments to pages), I did feel that it deserved a mention that the solution may not work on the T43. If anyone can confirm or deny this statement, please do so (and possibly ask on the ML for solutions if it does not work for you). --Kevinoid 05:44, 14 Dec 2005 (CET)

Confirmation - patch not working on T43

I can confirm, that a "nvram/cmos" patch is not working on my T43, exact type 1871-A62. I tried several cards (some working without patch in another thinkpads (t40, t42, x40), but no success.--Jap 09:50, 13 June 2006 (CEST)

Hotplugging PCI device

I'd like to send out a BIG FAT WARNING that 'hotplugging' the mini-PCI card can easily lead to frying the system board, mini-PCI bus, or both. Yes, it happened to me... :-( Interrupting the boot process at the lilo boot menu, and then inserting the ipw2915abg card worked as a charm to circumvent the BIOS white list. However, somewhere it must have gone wrong because now the laptop hangs immediately when the IBM/Intel boot logos appear. --LJSBrokken 13:01, 20 July 2006 (GMT+1)

Z60 series

I tried this on a Lenovo Z60t. Bought an Intel Wireless card since the linux drivers for the madwifi are crap. I applied the C-Patch from here. Then after booting with the intel device installed I get some weird broadcom PXE boot messages displayed ontop of the key symbol for startup security. Even if I don't put my finger on the sensor, it continues with GRUB. At this point I can't use the keyboard, the key symbol is still displayed in the upper left corner. After a few secons grub starts with its default entry (Gentoo Linux). It all works, but no Wireless Adapter shows up in lspci.

So, I don't have that 1802 error, but still can't use my wifi card. Any ideas?


I have tested the C code in my Z60t. I have BIOS 1.24 and Embedded Controller 1.18. Nvram was succesfully changed, but no difference in how the bios work: with original card works properly and no strange errors. With Atheros AR9285: still Unauthorized error. --Msxisalive 20:20, 15 April 2010 (UTC)

G40 series

According to [forum post], the CMOS hack (I assume they are referring to the bit-twiddling code) works. Does anyone else have anything to confirm this? I might well try it myself (in which case I'll update the main table), but I'll have to at least get an aerial first.


no dice on T43

Also can confirm the T43 is much more resistant to the unauthorized mini pci card problem. No 1802 didn't work (it worked for my T40). Changing the PCI class id to 0x0280 (networking device - other) also didn't shake the message. Finally, I tried to masquerade the card as a one of the whitelisted ones via the ath_info utility from madwifi. I made a mistake at this point and didn't update the subsystem vendor id / subsystem device id, just the primary pci vendor and device ids. I *still* got the warning message, and now the ath driver doesn't pick up the card, so I can't use ath_info. The card is basically bricked, unless I find time (ha ha) for some kernel hacking. Moral of the story is be careful with ath_info.

You should be able to use ath_info _without_ the madwifi driver use some low level pci tool to manually configure the card. Have a look into the source code comments at the begin of ath_info.c. On the other hand adding a new set of vendor ids in the madwifi driver isn't a big deal either. - jal2

IBM R40e

Have an IBM R40 & R40e, R40 - linux no-1802 cd worked flawlessly, r40e - linux no-1802 cd - hangs on confirmation the patching - maybe a keyboard error, but I dont have dock nor USB keyboard to try, the DOS CD, worked perfectly on the r40e (although I was a little nervous about bricking the R40e ;-). A little note - the r40e obviously dont have an antena - i'll have to get some, but its working even without antena for short range indoor (the accesspoint is about 3 meters away)

Other issues with unauthorized cards

I'm not sure if this is common but my Intel Pro 2915ABG (not from IBM) works on my T41 (both from eBay so some patch was probably already applied) except that the WLAN LED on the laptop stays off all the time. If this is common to all non-authorized cards, this wiki article should mention this. (yak - 24.01.2004)

It does the same for my r40 and not IBM intel 2200, I think that the led would work only if the PCI ID of the minipci card would be changed to IBM, but i dont know excatly how to do this, I just remember seeing it somewhere (kajencik - 24.01.2008)

I now know that someone changed the PCI-ID of my Intel 2915ABG card so it looks like an IBM one. Yet the LED didn't work. However, I've found a way to fix this: see here. Changing PCI-ID is quite easy, see this (also helpful: Patching the EEPROM section of Ipw2200 article). (yak - 4.03.2008)

I've added a new section called "Problem with WiFi LED". Comments and contributions are welcome. (yak - 5.03.2008)

IBM Thinkpad R31

I have the BIOS hacked in my R31 so it boots with the unauthorized card and XP picks it up, but XP will randomly lock up with the current card (Atheros 5005G) I have tried another of the same chipset and it does the same thing. What I shall try soon is to swap the 5005G with a friend for a Realtek card from his laptop. Does anyone know if there is an incompatibility issue with Atheros card in the R31?

dead links

i'm just trying to fix the 1802 error, but several links indicated in the useful solutions section don't work any more:

well, it remains to compile and run (as root) the C-code, which was written by Matthew Garrett. that seems to be easy and has worked for t40, ubuntu and a broadcom pci card, according to the list of successful BIOS modifications (in this case only the CMOS has to be changed, which is more secure). therefore i'll try it. but is anyone able to retrieve equivalent links or to upload the live cd again? --Jwollbold 22:03, 6 September 2008 (CEST)

Success on X61s

I bought a non-IBM Intel 4965 from eBay and was able to get it running without twiddling the BIOS. I'm running Ubuntu Intrepid.

  • The X61s doesn't seem to check the second Mini PCIe slot (near the audio sockets) against the whitelist. The antenna cables are long enough to reach if you (carefully) untape them from the plastic cover sheet.
  • The card reported that the killswitch was always on, regardless of its actual state. I assume that it's only wired to the first PCIe slot. I got around this by taping over pin 20 with a tiny piece of a post-it note. (I can come up with some photos if it helps).

This disables the killswitch, but it never worked with the original Atheros card anyway, so it's no big loss to me.

Interestingly, I had no problems running the machine with two WiFi cards. I recall that others have reported the BIOS complains if there are two. Maybe someone has a use for this.

How many people have really successfully taped over a MiniPCIe PiN

I keep finding instructions to "tape over PiN 20", or "just tape PiN 18" and this casually dispensed advice seems like disingenuous rebroadcasts of something they've never done themselves. The PiNs are smaller than the tip of a pen, even a ThinkPad stylus is wider. The task itself is frustrating and should be undertaken with a new, sharpest of razor blades, a good magnifier glass/visor in a well lit area on a stable surface. Anyone should thoroughly research a software based solution for your hardware/unsupported card combination before attempting to tape over a MiniPCI-e PiN.

  • Tested on X230, taped pin 20 and tried both half-mini-PCIE and WWAN mini-PCIE slots, didn't work - MagicFab 17:43, 9 January 2013 (CET)
  • Success on T500, placed an unmodified Broadcom 4311 in the second slot, no 1802 error but the card wouldn't work. It worked after taping over pin 20. It was not particularly difficult. User:Bigstape 9 January 2014
  • Tested on T420s, using Qualcomm Gobi 2000. Taped pin 20 and after that the device worked. Before, it was detected but could not connect. With regard to how difficult this is--I managed with just a role of cellotape and a pair of scissors. It took some concentration but I didn't need a razor or magnifying glass. User:PJBrs 3 June 2014